sábado, janeiro 25, 2020
Home » Office » Excel & Access » Como evitar que apareça o erro #N/D na função PROCV

Como evitar que apareça o erro #N/D na função PROCV

Saudações, caros!
Recentemente tive um problema em uma formula Procv onde quando não encontrava o item, retornava #N/D. Segue resolução que apliquei:




O erro #N/D surge na função PROCV quando o referido valor não foi encontrado na base de dados que você definiu. Para evitar que ele apareça podemos utilizar a função ÉERROS, veja como:

=SE(ÉERROS(PROCV(A1;B1:C8;2;0));””;(PROCV(A1;B1:C8;2;0)))
Ou seja, Se a função PROCV trouxer como valor algum erro, apareça “nada”, se não utilize a função PROCV.
Um abraço, até a próxima!

Sobre Diego Duarte

Diego Duarte é Gerente de Suporte, com mais de 7 anos de experiência em Data Center, e de quebra, arranha um violãozinho aos finais de semana

Gostou do conteúdo? Deixe seu comentário