segunda-feira, agosto 19, 2019
Home » Programação/ Scripts » Exercício Visualg e Pascal

Exercício Visualg e Pascal

Saudações, segue exercício  e correção:

Enunciado:

Escreva o pseudocódigo referente ao programa abaixo (o fluxograma apresenta um estrutura condicional encadeada:
OBS: o fluxograma faz a leitura de NOME e SEXO de uma pessoa e compara se está apta para o serviço militar. Para estar apta deve ser do sexo MASCULINO e ter idade entre 16 e 20 anos. Também é realizado a leitura de uma variável SAUDE para testar se o mesmo não ter problemas de saúde.


Código para Visualg:
Testei o o código no Visualg e está perfeitamente funcional. Ao copiar e colar, verifique as aspas e as letras maiúsculas e minúsculas.

algoritmo “Alistamento”
// Função :
// Autor :
// Data : 21/10/2012
// Seção de Declarações
var
nome, saude, sexo: caracter
idade: inteiro
inicio
Escreva (“Entre com o nome:”)
Leia (nome)
Escreva (“Entre com o sexo F/M:”)
Leia (sexo)
Se sexo = “F” entao
Escreva (“Não esta apto por ser do sexo feminino”)
Senao
Escreva (“Entre com a idade:”)
Leia (idade)
Se (idade <=16) ou (idade >=20) entao
Escreva (“Não esta apto pelo motivo da idade. A idade deve ser entre 16 e 20 anos”)
Senao
Escreva (“Entre apto para Saúde S/N:”)
Leia (saude)
Se saude = “S” entao
Escreva (“Esta apto”)
Senão
Escreva (“Não esta apto pelo motivo de saúde”)
Fimse
Fimse
Fimse
fimalgoritmo
Código Pascal
Para você estudante de Visualg, é importante estudar também Pascal; pelo fato de ser praticamente a mesma coisa, mas em inglês, o que certamente facilitará sua vivência na área de TI.
program Alistamento;
uses Crt;
{ Função :}
{ Autor :}
{ Data : 21/10/2012}
{ Seção de Declarações}
var
nome, saude, sexo: string;
idade: integer;
begin
write (‘Entre com o nome:’);
readln (nome);
write (‘Entre com o sexo F/M:’);
readln (sexo);
if sexo = ‘F’ then begin
write (‘Não esta apto por ser do sexo feminino’);
end else begin
write (‘Entre com a idade:’);
readln (idade);
if (idade <=16) or (idade >=20) then begin
write (‘Não esta apto pelo motivo da idade. A idade deve ser entre 16 e 20 anos’);
end else begin
write (‘Entre apto para Saúde S/N:’);
readln (saude);
if saude = ‘S’ then begin
write (‘Esta apto’);
end else begin
write (‘Não esta apto pelo motivo de saúde’);
end;
end;
end;
end.
Espero que seja útil no aprendizado. Até a próxima!

Sobre Diego Duarte

Diego Duarte atua como coordenador de suporte, é apaixonado por TI e arranha um violãozinho nos finais de semana

Gostou do conteúdo? Deixe seu comentário