Scripts

Pilhas em VisualG

327 views
3 Comentários
4
(2)

Saudações a todos.
Todos os estudantes de tecnologia sempre se deparam com pilhas, pensando nisso, temos no Purainfo pilhas em C++, Pilhas com String em C++. Agora, graças ao programador Salvador da Pátria Jefferson costa, temos uma Pilha com “Locadora de Livros” em Visualg.

algoritmo "locadora de livros"
var
topo, n, aux, posicao : inteiro
vet : vetor [1..3] de caracter
y, opcao : caracter
k: inteiro
data: caracter
nome: caracter
inicio
n <- 3
topo <- 0
repita
limpatela
escreval ("Nossa locadora de livros")
escreval (" ")
escreval (" ")
para k de n ate 1 passo -1 faca
  escreval (k, " ... " , vet[k])
fimpara
escreval ("incluir ... 1")
escreval ("Topo...... ", topo)
escreval (" ")
escreval ("---------------------------------------------")
escreval (" ")
escreval (" ")
escreval( "Menu Operacoes")
escreval( "0 - Sair")
escreval( "1 - ALUGAR")
escreva ("Escolha uma opcao ... ")
leia(opcao)
se opcao = "1" entao
   escreva( "Informe o nome do livro ... ")
   leia(y)
   escreval ( "Informe o nome do cliente ... ")
   leia(nome)
   escreval ( "Data do emprestimo ... ")
   leia(data)
escreval( " " )
se topo = n entao
    escreval ("Overflow - Inclusao Nao Executada - pressione enter")
    leia(y)
    senao
    topo <- topo + 1
    vet[topo] <-y + nome + data
fimse
fimse
ate opcao="0"
fim algoritmo

É isso aí. Até a próxima, e sinta-se a vontade para postar mais, Jefferson.

O que você achou disso?

Média da classificação 4 / 5. Número de votos: 2

Nenhum voto até agora! Seja o primeiro a avaliar este post.

Como você achou esse post útil...

Ajude o site a crescer compartilhando o conteúdo

Lamentamos que este post não tenha sido útil para você!

Vamos melhorar este post!

Diga-nos, como podemos melhorar este post?

Tags:

Artigos Relacionados

3 Comentários. Deixe novo

Gostou do conteúdo? Deixe seu comentário

Veja também

Menu